$re = '/default = ssh:\/\/webfaction\/\/home\/mwolfe02\/webapps\/hg\/repos\/(.*)$/m';
$str = 'default = ssh://webfaction//home/mwolfe02/webapps/hg/repos/loan_mgmt';
$subst = "default = ssh://opal//home/gb/repos/$1\nwebfaction = ssh://webfaction//home/mwolfe02/webapps/hg/repos/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;