$re = '/\d{4}-\d{2}-\d{2}/mi';
$str = 'ejennsd 2022-07-28T03:00:00.000Z skdjkdc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);