package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?`)
var str = `Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)(\.\d+)([a-zA-Z]*)\s(\w*)( X )(\d+)([a-zA-Z]*)\s(\w*) - works for 3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}