package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\W_]{3,48}$`)
var str = `ss7`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}