package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z]+(\.|_)?([a-z0-9]+(\.|_)?)+?[a-z0-9]+@[a-z0-9]+_?[a-z0-9]+\.[a-z]+`)
var str = `mohamed@yahoo.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}