re = /[w]|[ate](?=\*)|\b[pa](?=[^a-z])|\b[^(e|_)\d\W]\b/mi
str = '(1)/(2)+p_a*r*e*t*a*v+pi+\\delta+\\sigma
(1)/(2)+a_t*e*j*h*o+ \\Delta
(1)/(2)+p_w'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end