#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\R(.+)$"
Local $sString = "Wyoming" & @CRLF & _
"Alaska" & @CRLF & _
"South Dakota" & @CRLF & _
"Montana" & @CRLF & _
"Vermont" & @CRLF & _
"North Dakota" & @CRLF & _
"West Virginia" & @CRLF & _
"Hawaii" & @CRLF & _
"New Mexico"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")