Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[!"]+([^!"]+)[!"]
/
gm
Test String
New
!img2.png|width=83.33333333333334%! "!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!" "!abc.pdf|width=200!" "!dfe.xlx" !"dfe.xlx!"