package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(abc.?\s*(\b\s\w+\s\b){0,7}\s*\bsome\s*name\b)`)
var str = `abc/ef 12,345 some name
abc/ef 12345 some name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}