use strict;
my $str = 'height(female), weight, BMI, and BMI.
height(female), weight, whatever it is, and whatever it is.
height(female), weight, age, height(female), and BMI.
weight, weight.';
my $regex = qr/(?<=, |^)\b([()\w\s]+),\s(.*?)((?: and)?(?=\1))|\w=\(.*?\)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";