#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"{3}(?>(?<!\\"{3}).)+?"{3}"
Local $sString = """"asdasd"""" & @CRLF & _
""""a"sda""sd"""" & @CRLF & _
""""a"s"dasd"""" & @CRLF & _
""""asdas"d"""" & @CRLF & _
""""a""sd""a\"""sd"""" & @CRLF & _
""""asd\"""a""sd"""" & @CRLF & _
""""asd"""sdfsdf"""" & @CRLF & _
""""a"sd"""sdfsdf"""s""df""""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")