#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>(?<!\\""").)+$"
Local $sString = """"asdasd""" // group (полное соотвествие)" & @CRLF & _
"" & @CRLF & _
""""a"sda""sd""" // group (полное соотвествие, нет трёх кавычек)" & @CRLF & _
"" & @CRLF & _
""""a"s"dasd""" // group (полное соотвествие, нет трёх кавычек)" & @CRLF & _
"" & @CRLF & _
""""asdas"d""" // group (полное соотвествие, нет трёх кавычек)" & @CRLF & _
"" & @CRLF & _
""""a""sd""a\"""sd""" // group (полное соотвествие, группа заэкранированна)" & @CRLF & _
"" & @CRLF & _
""""asd\"""a""sd""" // group (полное соотвествие, группа заэкранированна)" & @CRLF & _
"" & @CRLF & _
""""asd"""sdfsdf""" // group + sdfsdf (соотвествие только первой части)" & @CRLF & _
"" & @CRLF & _
""""a"sd"""sdfsdf"""s""df""" // group + sdfsdf + group (соответствие двум группам)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")