$re = '`[\x{1F000}-\x{1FFFF}|\x{20a0}-\x{32ff}|\x{fe4e5}-\x{fe4ee}|\x{200D}]+`m';
$str = '🙌🏻
1F64C 1F3FC sd
😈
🏿
👩🏾🤝👨🏿
👩🏾🤝👨🏿
👨👩👦';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);