// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(\d+)\](:\s)([A-Z]*)").unwrap();
let string = "July 31 07:51:48 mycomputer bad_process[12345]: ERROR Performing package upgrade";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}