using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?=(.*?([a-z]))(?!.*\2))\1){26}";
string input = @"The quick brown fox jumps over a lazy dog.
Watch ""Jeopardy!"", Alex Trebek's fun TV quiz game.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}