import Foundation
let pattern = #"(?:\A|\n{2})(?:(?!\n{2}).)+\.(?=\n{2}|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
Diagnosis of one of the following: A) Neovascular (wet) age-related
macular degeneration OR B) Macular edema following retinal vein
occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in
patients with diabetic macular edema. More text here.
PA Criteria
Criteria Details
Eylea (s)
Products Affected
EYLEA
Exclusion
Criteria
Required
Medical
Information
Age Restrictions
Prescriber
Restrictions
Coverage
Duration
Other Criteria
Off Label Uses
12 months
Indications
All Medically-accepted Indications.
Formulary ID 20276, Version 12
101
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)