$re = '/^\s*(,\s*)*|,\s*(?=,|$)/';
$str = ',,,, \'time_hour\', \'loc\', \'protocol_category\', , \'mcc\', \'imsi\', \'service_dl_bytes\', , ,,,,,,,,
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;