// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]").unwrap();
let string = "Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O'Donnell]
[Anne-Marie O'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]";
let substitution = "$1\\:";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}