re = /(?=(word1|word2|word3)).*?(?!\1)((?1)).*?(?!\1)(?!\2)((?1))/m
str = 'a word3 word3 word2 word 2 word1 word2 word1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end