$re = '/\b(\w+\.(png|jpeg|gif|jpg))\b/m';
$str = 'flower.png is photo
photo001.png is also image file
-001bikini.jpg is photo file
I save file 02beach.gif to computer
wallpaper.jpeg is also photo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);