import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"CharOverride-7\">(.*)<\\/span>";
final String string = "<p class=\"2\"><span class=\"CharOverride-7\">A book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net</span></a><span class=\"CharOverride-7\">.</span></p>\n\n"
+ " <p class=\"2\"><span class=\"CharOverride-7\">Another book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net/</span></a><span class=\"CharOverride-7\">.</span></p>\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}