use strict;
my $str = 'je vader window.__AH_DATA__= {gert}\\n\\n window.__APOLLO_STATE__= {} je moeder';
my $regex = qr/(window\.__AH_DATA__= {.*}\\n\\n window\.__APOLLO_STATE__= {})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";