$re = '/(?:ACT|SCENE).+?\d+|\S.*?(?=\s?(?:ACT|SCENE|$))/m';
$str = 'Hi this is ACT I. SCENE 1 and SCENE 2 and this is ACT II. SCENE 1 and SCENE 2 and more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);