// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/([^\s]+)").unwrap();
let string = "https://site.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/{{ type }}
https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/link
текст текст https://site.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/{{ type }} текст текст https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/link";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}