package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/([^\s]+)`)
var str = `https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст
https://diso.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст
https://diso.ru/{%iftype=='webinar'%}webinar{#comment#}{%else%}profile{{type}}{%endif%}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}