use strict;
my $str = 'nextflow.enable.dsl=2
// params.module_dir = \'.\'
params.dbs_dir = \'/mnt/OmicNAS/dd/alphafold/dbs\'
params.max_template_date = \'2020-05-14\'
params.db_preset = \'reduced_dbs\'
params.model_preset = \'monomer\'
params.outdir = \'./\'
params.cachedir = \'/mnt/OmicNAS/cache/alphafold\'
process ALPHAFOLD {
conda "${moduleDir}/environment.yml"
echo true
maxForks 1
stageInMode \'copy\'
storeDir "${params.cachedir}"
publishDir "${params.outdir}", mode: \'copy\'
input:
path fasta
output:
path "*", emit: outputs
script:
"""
python3 ${moduleDir}/docker/run_docker.py \\
--fasta_paths=${fasta} \\
--max_template_date=${params.max_template_date} \\
--model_preset=${params.model_preset} \\
--db_preset=${params.db_preset} \\
--data_dir=${params.dbs_dir} \\
--output_dir=\\$PWD
"""
}
';
my $regex = qr/process\s+(\w+|\"[^\"]+\"|'[^']+')\s*{((.|\n|\r)*)}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}