# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"process\s+(\w+|\"[^\"]+\"|'[^']+')\s*{((.|\n|\r)*)}"
test_str = ("nextflow.enable.dsl=2\n\n"
"// params.module_dir = '.'\n"
"params.dbs_dir = '/mnt/OmicNAS/dd/alphafold/dbs'\n"
"params.max_template_date = '2020-05-14'\n"
"params.db_preset = 'reduced_dbs'\n"
"params.model_preset = 'monomer'\n"
"params.outdir = './'\n"
"params.cachedir = '/mnt/OmicNAS/cache/alphafold'\n\n"
"process ALPHAFOLD {\n"
" conda \"${moduleDir}/environment.yml\"\n\n"
" echo true\n\n"
" maxForks 1\n\n"
" stageInMode 'copy'\n\n"
" storeDir \"${params.cachedir}\"\n\n"
" publishDir \"${params.outdir}\", mode: 'copy'\n\n"
" input:\n"
" path fasta\n\n"
" output:\n"
" path \"*\", emit: outputs\n\n"
" script:\n"
" \"\"\"\n"
" python3 ${moduleDir}/docker/run_docker.py \\\n"
" --fasta_paths=${fasta} \\\n"
" --max_template_date=${params.max_template_date} \\\n"
" --model_preset=${params.model_preset} \\\n"
" --db_preset=${params.db_preset} \\\n"
" --data_dir=${params.dbs_dir} \\\n"
" --output_dir=\\$PWD\n"
" \"\"\"\n"
"}\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.