const regex = new RegExp('__\\([\\s]?\\'([^\\']*?)\\'[\\s]?\\)', 'g')
const str = `\$schedules['fiveminute'] = array(
'interval' => 300,
'display' => __('Every 5 minutes')
);
return \$schedules;
return array(
'success' => true,
'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}