// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"__\([\s]?'([^']*?)'[\s]?\)").unwrap();
let string = "$schedules['fiveminute'] = array(
'interval' => 300,
'display' => __('Every 5 minutes')
);
return $schedules;
return array(
'success' => true,
'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)
);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}