#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).+?_([0-9]+)?_.+"
Local $sString = "foobar_foobar_190412_foobar_foobar.jpg" & @CRLF & _
"foobar_20190311_2372_foobar.jpg"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)