// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+?_([0-9]+)?_.+").unwrap();
let string = "foobar_foobar_190412_foobar_foobar.jpg
foobar_20190311_2372_foobar.jpg";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}