use strict;
my $str = '(STUNNEL-SECURITY AND NOT (
eventtype=sec-stunnel-client-*
OR eventtype=sec-stunnel-crl-*
OR eventtype=sec-stunnel-loaded-*
OR eventtype=sec-stunnel-loading-*
OR eventtype=sec-stunnel-no-*
OR eventtype=sec-stunnel-openssl-*
OR eventtype=sec-stunnel-sconnect-*
OR eventtype=sec-stunnel-server-*
OR eventtype=sec-stunnel-service-*
OR eventtype=sec-stunnel-session-*
OR eventtype=sec-stunnel-socket-*
OR eventtype=sec-stunnel-ssl-*
OR eventtype=sec-stunnel-stats-*
OR eventtype=sec-stunnel-threading-*
OR eventtype=sec-stunnel-timeout-*
OR eventtype=sec-stunnel-various-*
) )';
my $regex = qr/eventtype=\K\S+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}