package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\'{2,}`)
var str = `aaaaa''''a'''a''x1'sdd`
var substitution = "'"
fmt.Println(re.ReplaceAllString(str, substitution))
}