const regex = /\'{2,}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\'{2,}', 'gi')
const str = `aaaaa''''a'''a''x1'sdd`;
const subst = `'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);