package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)posta2010@(.*)`)
var str = `posta2010@apple.com
ddd@apple.csom
posta2010@dddd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}