# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\n)[\r\n]+|(<text>.*?<\/text>)/$1$2/isug;t' <<< "String 1
String 2
<tag1>
Tag str 1
Tag str 2
</tag2>
<text>
Text
Text 2
Text 3
</text>
"