package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1[01]*(?:\.[01]{0,31}1)?$`)
var str = `1.001100101
1.0000000000000010
1
0
0.1
1..1
1.1
1.000000000000001
1.01010101010101010101010101010101
1.010101010101010101010101010101011
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}