re = /\{"acks":"(\d+)"\}/m
str = '[{"acks":"6"},{"acks":"7"},{"acks":"8"}]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result