# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s\|\s)|(?:\s\|)|(?:\|\s)/|/g;t' <<< "12| 150 | test one| 33235
13| 151| test two |33236"