#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\s\|\s)|(?:\s\|)|(?:\|\s)"
Local $sString = "12| 150 | test one| 33235" & @CRLF & _
"13| 151| test two |33236"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)