package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s\|\s)|(?:\s\|)|(?:\|\s)`)
var str = `12| 150 | test one| 33235
13| 151| test two |33236`
var substitution = "|"
fmt.Println(re.ReplaceAllString(str, substitution))
}