const regex = /(?:\s\|\s)|(?:\s\|)|(?:\|\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s\\|\\s)|(?:\\s\\|)|(?:\\|\\s)', 'g')
const str = `12| 150 | test one| 33235
13| 151| test two |33236`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);