use strict;
my $str = '12| 150 | test one| 33235
13| 151| test two |33236';
my $regex = qr/(?:\s\|\s)|(?:\s\|)|(?:\|\s)/p;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";