re = /\bjava\b(?!\.)/m
str = 'JAVA_VERSION=$("java" -version 2>&1 | awk -F \'"\' \'/version/ {print $2}\')
$java -DagentVersion=2.6.0 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.reflect=ALL-UNNAMED -jar'
subst = '/opt/java17'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result