$re = '~(?=.*insert)(?=.*name).+~';
$str = 'I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match.
this line not
this insert neither
neither name
but insert and name !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);