#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\<\%[\w \@\=\.\*\,\"\$\#\!\&\(\)\/\/\n\+\;\:]*"
Local $sString = "<%@ page import="java.io.*,java.util.*" %>" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>Auto Refresh</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <fieldset style="width:20%; background-color:#e6ffe6;">" & @CRLF & _
" <legend>Auto refresh</legend>" & @CRLF & _
" <h2>Auto Refresh Example</h2>" & @CRLF & _
" <%" & @CRLF & _
" // Set refresh, autoload time as 1 seconds" & @CRLF & _
" response.setIntHeader("Refresh", 1);" & @CRLF & _
" // Get current time" & @CRLF & _
" Calendar calendar = new GregorianCalendar();" & @CRLF & _
" String am_pm;" & @CRLF & _
" int hour = calendar.get(Calendar.HOUR);" & @CRLF & _
" int minute = calendar.get(Calendar.MINUTE);" & @CRLF & _
" int second = calendar.get(Calendar.SECOND);" & @CRLF & _
" if(calendar.get(Calendar.AM_PM) == 0)" & @CRLF & _
" am_pm = "AM";" & @CRLF & _
" else" & @CRLF & _
" am_pm = "PM";" & @CRLF & _
" String CT = hour+":"+ minute +":"+ second +" "+ am_pm;" & @CRLF & _
" out.println("Crrent Time: " + CT + "\n");" & @CRLF & _
" %>" & @CRLF & _
" </fieldset>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")