use strict;
my $str = 'd ,c ,bb ,a
h ,g ,f ,ee
l ,kk ,j ,i
';
my $regex = qr/(\w+)(?=.*,(\w+)$)|\s+,\w+$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";