# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:href=|src=|url\()(?:[\",']?)(.*image3\.png)[\",',\)]+?"
test_str = ("<!DOCTYPE html>\n\n"
"<html lang=\"en\">\n\n"
"<head>\n"
" <meta charset=\"utf-8\" />\n"
" <title></title>\n"
" <meta name=\"description\" content=\"\" />\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1, maximum-scale=1\" />\n\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n"
" <link rel=\"stylesheet\" type=\"text/css\" href=\"style.css\" />\n"
"</head>\n\n"
"<body>\n"
" <div class=\"wrapper\">\n"
" <img src=\"image1.png\" alt=\"description goes here\">\n"
" <img src=\"image2.png\" alt=\"description goes here\">\n"
" <img src=\"image3.png\" alt=\"description goes here\">\n"
" </div>\n\n"
" <p>This \"image3.png\" is not linked so it should be ignored</>\n"
" <p>This \"app.js\" is not linked so it should be ignored</>\n"
" <p>This \"style.css\" is not linked so it should be ignored</>\n\n"
" <script src=\"app.js\"></script>\n"
"</body>\n\n"
"</html>\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.