using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^A-Z\n]*[A-Z]){2,4}[^A-Z\n]*$).{6,12}$";
string input = @"Valid matches would be:
HamBurger
LeTtUce
TACOss
But invalid matches would be:
ABCDE1234
aBcDeFgHiJ
ADBC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}