re = /^(?=(?:[^A-Z\n]*[A-Z]){2,4}[^A-Z\n]*$).{6,12}$/m
str = 'Valid matches would be:
HamBurger
LeTtUce
TACOss
But invalid matches would be:
ABCDE1234
aBcDeFgHiJ
ADBC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end